Help DeskNew to SmugMug › What operating systems and browsers are supported by SmugMug?

What operating systems and browsers are supported by SmugMug?

Updated: 10/23/2014

Whether you're managing your own galleries or simply viewing someone's photos, it's a good idea to make sure the tools you're using are compatible with ours. We're flexible, but if something doesn't look right to you, check the system and browser specifications below.

Fully Supported Operating Systems and Browsers

Windows 8: IE10 and IE11; latest version of Firefox; latest version of Chrome

Windows 7: IE9, IE10, and IE11; latest version of Firefox; latest version of Chrome

Windows Vista: IE9; latest version of Firefox; latest version of Chrome

Mac OS X 10.7 and above: Safari 6 and above; latest version of Firefox; latest version of Chrome

Mac OS X 10.6: Safari 6 and above; latest version of Firefox; latest version of Chrome

We love Chrome and Firefox, and they're both free and easy to install. They'll work on both Mac and PC.

FYI: We really support production-ready browsers, so if you're using a beta version and something looks funny, please try one of the browsers listed above.

Mobile Devices

Not at your desk? Not a problem.

  • View your site on any mobile device via our quick-loading mobile site.
  • Watch HTML5 slideshows on iPads and iPhones.
  • Download our app for iOS.
  • Download our app for Android.

Other Goodies to Have

Javascript and cookies must be enabled, and Adobe Flash 11 (or above) should be installed in all browsers.

Need help with Javascript?

  1. Boston University has some great diagnostic tools on their site that you can access right here.
    • Click Start SSL Test to begin.
    • You'll then see a Test link on the right, so click it to run the individual check.
    • The page will show you when your current browser passes the four tests. The little help link on each line will also provide more information about each one.
  2. For more assistance, this site provides great step-by-step instructions on how to get Javascript working in most browsers.
  3. Of course if you're at the end of your rope you can always write our Support Heroes for help!

To use our Simple uploader, Java is required.

Are You a Linux User?

Cool! While not officially supported, most things on SmugMug will work just fine using Firefox 4 and above. If you're stuck, we have help on our support forum right here.